Mail Server Issue
Incident Report for 3dcart
Resolved
The issue has been resolved and access re-established.
Posted 3 months ago. May 08, 2018 - 12:24 EDT
Identified
We identified and are already working on an issue affecting one of our mail servers.
ETA: 10 minutes.
Posted 3 months ago. May 08, 2018 - 12:23 EDT