Emergency Maintenance
Incident Report for 3dcart
Resolved
At this time, maintenance has been completed and services have been resumed.
Posted 3 months ago. Aug 30, 2018 - 06:16 EDT
Identified
We are performing an emergency maintenance on some environments. Some customers will experience downtime.
Posted 3 months ago. Aug 30, 2018 - 02:08 EDT