Phone system Maintenance
Incident Report for 3dcart
Resolved
Phone system is up.
Posted Sep 12, 2020 - 00:07 EDT
Investigating
3dcart IT Department has scheduled a phone maintenance on 9/12/2020. We encourage all customers to use the chat support via their stores admin panels instead of calling the center during the maintenance time.
Friday midnight - Saturday 12:01 am 9/12/2020
Posted Sep 11, 2020 - 23:53 EDT
This incident affected: Ticket System.