Mail Services Issues
Incident Report for 3dcart
Resolved
The issue has been resolved. Only web access had a temporary down time and only affected a few customers.
Posted about 1 month ago. Nov 12, 2018 - 17:59 EST
Investigating
Our monitoring systems detected issues on one or more of our mail servers. The problem is already being investigated by our network engineers. We will provide updates as more details are available or once the issue has been fixed. If you have any questions please contact our support team.
Posted about 1 month ago. Nov 12, 2018 - 17:53 EST
This incident affected: Mail Server.