Mail Services Issues
Incident Report for 3dcart
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 16, 2019 - 13:06 EDT
Update
Our mail system issues are resolved. If you experiencing any issues with receiving mail, please contact our team.
Posted about 1 month ago. Sep 13, 2019 - 18:03 EDT
Investigating
Our monitoring systems detected issues on one or more of our mail servers. The problem is already being investigated by our network engineers. We will provide updates as more details are available or once the issue has been fixed. If you have any questions please contact our support team.
Posted about 1 month ago. Sep 13, 2019 - 14:11 EDT
This incident affected: Mail Server.