Mail Services Issues
Incident Report for 3dcart
Resolved
The issues affecting several online stores have been resolved and access has been re-established. All affected stores are now up and running! We'll continue to provide status updates on this page as needed.
Posted 5 months ago. Apr 22, 2019 - 11:31 EDT
Investigating
Our monitoring systems detected issues on one or more of our mail servers. The problem is already being investigated by our network engineers. We will provide updates as more details are available or once the issue has been fixed. If you have any questions please contact our support team.
Posted 5 months ago. Apr 21, 2019 - 11:59 EDT
This incident affected: Mail Server.